Go Back   Catalyst Athletics Forums > Nutrition > General Nutrition

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-10-2008, 12:40 PM   #1
sarena kopciel
Senior Member
 
Join Date: Dec 2006
Posts: 674
Default Lab Numbers

Ok so I wasnt sure where post this but here goes (again). I have been feeling pretty lousy for a while now (several weeks) and when I had difficulty lifting a 8# pot the other day I figured I had to go to the doc. I have been tired, achy, shoulder injury isnt healing etc. I thought maybe mono, Lyme...who knows!

Anyway the doc redid all my labs and although the Lyme stuff isnt back yet, my chol and blood glucose has changed significantly (I think). Remembering all along I was diagnosed with type 2 diabetes several years ago but that has been controlled. I have been mostly paleo nearing 2 years with IF added in as well.

Current labs------- 10/07
Glucose 116--------not reported
Chol ttl 223--------------- 156
hdl 56-------------------- 63
chol/hdl ratio 4.0------------- 2.5
LDL 146-------------------- 85
Triglyc. 106---------------------41
Ha1C 5.7----------------------5.9

No I do see the clear diff in blood sugar as good but are the lipid numbers problematic?
sarena kopciel is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -7. The time now is 03:06 AM.

Powered by vBulletin® Version 3.8.9 Beta 3
Copyright ©2000 - 2014, vBulletin Solutions, Inc.